Stremio video error. (vlc)

Behöver du hjälp?
snackfood
Inlägg: 7
Blev medlem: 23 jan 2018, 16:37

Stremio video error. (vlc)

Inlägg av snackfood » 24 jan 2018, 00:10

Hejsan!
Här kommer en liten fix till er här hemma som har problem med Stremio.
Jag upptäckte att Qnap's Stremio inte ville spela upp någon video alls som fanns lokalt eller inte, så jag felsökte och kom fram till att det var lib_vlc som var den felande faktorn.

Detta kräver lite kunskap om sFftp och om filsystemet på din Nas.

Det finns två tillvägasätt.

1 Du installerar VLC appen via App Center och ändrar så att Stremio använder VLC filerna från ditt nyss installerade VLC arkiv.
2 Du laddar ned lib_vlc och skapar en ny mapp någonstans och ändrar så att Stremio kör lib_vlc från det arkivet.

Här är filen du ska ändra lite i.
Så här ser det ut i mitt filsystem.
/share/CACHEDEV1_DATA/.qpkg/stremio/opt/Stremio.sh <-- Editera Stremio.sh på valfritt sätt.
Enklast är nog att ansluta med sftp via WinSCP eller liknande.

I raden näst längst ned så borde det stå ungefär så här.
LD_PRELOAD="./WCjs/vlc/lib/libvlc.so.5.5.0 ./WCjs/vlc/lib/libvlccore.so.8.0.0" ./Stremio-runtime . $@
kopiera den raden och sätt "#" före så att den ignorerar den där raden. ( spara den för eventuella typfel )

klistra in och ändra på raden så att den ser ut så här. ( eller dylikt beroende på ditt filsystem. )

LD_PRELOAD="/share/CACHEDEV1_DATA/.qpkg/VideoLAN/opt/lib_vlc/libvlc.so.5
/share/CACHEDEV1_DATA/.qpkg/VideoLAN/opt/lib_vlc/libvlccore.so.8" ./Stremio-runtime . $@

"./WCjs/vlc/lib/" ersätts med filsökvägen till dina libvlc filer.

Lycka till!